Degrade performance with Contacts

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:31 CET

Monitoring

The degradation has been mitigated and all service functionality has been fully restored.
Posted Dec 04, 2025 - 18:14 CET

Investigating

We are currently investigating a degraded performance with Contacts In the EU region which impacts but is not limited to Contacts pages, Journeys and Flows.
Posted Dec 04, 2025 - 17:16 CET
This incident affected: CRM (Contacts - Europe).