SMS delivery interruption - Netherlands - Odido 20416

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 17:31 CEST

Investigating

There is an ongoing disruption of the services provided by Odido NL.
All services are affected. The operator is aware, and they are dealing with this incident.
Posted Jun 25, 2025 - 13:27 CEST
This incident affected: Connectivity Platform (SMS - Connectivity - EMEA).