Overview pages and Search down

Incident Report for Bird

Resolved

This incident has been resolved.
Posted May 20, 2026 - 12:16 CEST

Investigating

We are currently investigating an issue where the overview pages for Journeys, Flows, Search and other products are down and unavailable.
Posted May 20, 2026 - 12:06 CEST