SMS delivery interruption - Honduras - Tigo 70802
Incident Report for Bird
Resolved
The delivery interruption affecting SMS messages has been resolved, and the service has returned to normal.
Posted Jan 23, 2025 - 20:32 CET
Identified
We are experiencing a service interruption affecting SMS message delivery. Our teams are actively working with the operator to resolve this issue.
Posted Jan 23, 2025 - 00:35 CET