Inbox Settings not all availible
Incident Report for Bird
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 05:43 CET
Update
The team was able to restore the site to its previous state.
Posted Mar 21, 2024 - 05:42 CET
Investigating
The team has is investigating an issue with certain settings pages not loading.
Posted Mar 21, 2024 - 05:18 CET
This incident affected: CRM (Inbox - Europe, Inbox - US (West), Inbox - Asia (India)).