Delays in processing a subset of flows & journeys contact-added-to-list triggers

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 16:07 CET

Investigating

We are currently investigating processing delays impacting a subset of flows & journeys configured with contact-added-to-list triggers.
Posted Mar 11, 2026 - 14:52 CET
This incident affected: CRM (Contacts - Europe, Contacts - US (West), Contacts - Asia (India)).