The fix has been deployed and all campaign metrics are now displaying correctly. All previously affected data is fully restored and available. If you continue to experience any issues with campaign metrics, please contact our support team.
Posted Jul 29, 2025 - 16:07 CEST
Identified
We are currently validating the fix in our staging environment before deploying to production. We will provide another update once the deployment is complete.
Posted Jul 29, 2025 - 15:29 CEST
Update
We have identified the root cause of the campaign metrics display issue and are implementing a fix. While metrics may appear unavailable or show zero values, no data has been lost and message transmission and delivery continue to operate normally. Once our mitigation is complete, all metrics will be fully restored and available again. We will provide another update shortly.
Posted Jul 29, 2025 - 15:05 CEST
Investigating
We are investigating reports of campaign metrics displaying incorrectly or appearing as zero values
Posted Jul 29, 2025 - 14:36 CEST
This incident affected: CRM (Analytics - Europe, Analytics - US (West), Analytics - Asia (India), Campaigns - Europe, Campaigns - US (West), Campaigns - Asia (India)).