Support-Center New Case Creation Error
Incident Report for Bird
Resolved
The engineering team has identified the issue and resolved it.
Posted Mar 15, 2024 - 19:49 CET
Investigating
Our engineering team is investigating an issue affecting customers creating new cases with support-center. The cases are not being created and returning errors.
Posted Mar 15, 2024 - 19:24 CET
This incident affected: CRM (Dashboard - app.bird.com).