Number Purchases failures

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 15:42 CET

Update

Our engineering team has released a fix and confirmed that the number purchase is now operational. We apologise for any inconvenience this may have caused.
Posted Jan 29, 2025 - 17:36 CET

Update

We are actively investigating this issue and can confirm that it occurs intermittently.
Posted Jan 29, 2025 - 15:24 CET

Investigating

Our engineering team is actively investigating an issue affecting number purchases on Bird CRM. Customers are encountering an error on the UI when attempting to complete a purchase
Posted Jan 29, 2025 - 15:11 CET
This incident affected: CRM (Dashboard - app.bird.com).