Issues Listing Journeys in UI [EU]

Incident Report for Bird

Resolved

This incident has been resolved.
Posted May 13, 2026 - 15:33 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 14:25 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 13, 2026 - 14:16 CEST

Investigating

We are currently experiencing an issue where journeys are not displaying in the user interface. Journey runs are not affected and continue to execute normally.

At this time, the issue is limited to the listing/viewing of journeys in the UI. Our engineering team is actively investigating the root cause.
Posted May 13, 2026 - 13:33 CEST
This incident affected: CRM (Journey - Europe).