Database Issue Causing Platform Performance Degradation

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 22:10 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 21:53 CET

Update

We have identified which hardware was causing the issues and are replacing it. We are already seeing some improvement and expect that to continue.
Posted Jan 27, 2026 - 21:31 CET

Update

The team has made additional adjustments and we have started seeing accelerated recovery of the cluster.
Posted Jan 27, 2026 - 21:27 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 27, 2026 - 20:55 CET

Investigating

We are currently experiencing a database performance issue that is impacting multiple platform services. Customers may encounter timeouts, slow response times, and intermittent errors when accessing the following areas:

* CDP (Customer Data Platform) - Data synchronization and profile updates may be delayed
* Campaigns - Campaign creation, editing, and sending operations may be affected

Our engineering team is actively investigating the database issue and working to restore normal service.
We will provide updates as we make progress toward resolution.
Posted Jan 27, 2026 - 19:56 CET
This incident affected: CRM (Analytics - US (West), Campaigns - US (West), Contacts - US (West)).