Delay in Contact Processing

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 18:08 CET

Update

We are continuing to investigate the issue with the US West Region.
Posted Mar 18, 2025 - 23:52 CET

Update

The issue is resolved in the EU region.

We are still working on the US WEST regions

We are investigating the situation and we will provide an update as soon as we have additional information.
Posted Mar 18, 2025 - 21:16 CET

Investigating

For recently created contacts/lists, we are investigating a delay in contact processing in US WEST and EU regions

We are investigating the situation and we will provide an update as soon as we have additional information.
Posted Mar 18, 2025 - 19:25 CET
This incident affected: Connectivity Platform (Inbox, Conversations - API, Messaging - API, Email Channel, WhatsApp Channel) and CRM (Contacts - Europe, Contacts - US (West)).