We have deployed the proposed workaround and full service functionality has been restored.
Posted Nov 26, 2025 - 12:12 CET
Update
Meta identified some issues regarding sign-up flows on their end and have provided a temporary workaround; we are in the process of confirming and deploying it.
Posted Nov 26, 2025 - 11:18 CET
Update
We are continuing investigations.
Posted Nov 26, 2025 - 10:25 CET
Update
We are continuing investigations alongside Meta engineering teams.
Posted Nov 25, 2025 - 10:30 CET
Update
Meta's engineering team has been engaged for investigations.
Posted Nov 24, 2025 - 18:43 CET
Identified
We have confirmed that impact is scoped to pre-verified numbers only. The issue has been escalated to Meta for further investigations.
Posted Nov 24, 2025 - 13:36 CET
Investigating
We are investigating issues preventing some customers from installing WhatsApp channels.
Posted Nov 24, 2025 - 12:47 CET
This incident affected: CRM (Channels - Europe, Channels - US (West), Channels - Asia (India)).