10DLC SMS campaign registration or number provisioning delays - United States

Incident Report for Bird

Resolved

The 10DLC campaign registration or number provisioning delays have been resolved, and service has returned to normal.
Posted Feb 03, 2025 - 17:27 CET

Update

We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 17:26 CET

Update

We are continuing to work on a fix for this issue.
Posted Feb 01, 2025 - 01:16 CET

Identified

We are experiencing delays with 10DLC campaign registration and number provisioning. Our teams are working to restore normal processing times.
Posted Feb 01, 2025 - 01:09 CET
This incident affected: Connectivity Platform (SMS - Connectivity - NORAM).