New campaign activation failures in EP marketing suite

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:47 CEST

Monitoring

A fix has been implemented and we are monitoring the results. Affected customers are advised to retry their campaigns.
Posted Mar 31, 2026 - 14:25 CEST

Identified

We are currently investigating an issue impacting campaigns activated in the EP Marketing Suite within the last 30 minutes. Affected campaigns are failing approximately 10 minutes after activation.

Our team is actively working on a fix.
Posted Mar 31, 2026 - 13:29 CEST
This incident affected: CRM (Campaigns - Europe, Campaigns - US (West), Campaigns - Asia (India)).