Journey Processing Delays [EU]

Incident Report for Bird

Resolved

This incident has been resolved.
Posted May 12, 2026 - 16:16 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 15:58 CEST

Investigating

We are currently experiencing delays in processing journeys. The team is actively working to increase processing speed and reduce delays.
Posted May 12, 2026 - 15:41 CEST
This incident affected: CRM (Journey - Europe).