A portion of emails are currently not appearing on Inbox
Incident Report for Bird
Resolved
Our engineering team has confirmed that this issue has been resolved and impacted only a small subset of our email traffic on Inbox. We apologise for any inconvenience caused.
Posted Nov 08, 2024 - 18:58 CET
Investigating
Our engineering team is investigating an issue where a portion of emails are currently not appearing on Inbox for some users.
Posted Nov 08, 2024 - 18:18 CET
This incident affected: CRM (Inbox - Europe, Inbox - US (West), Inbox - Asia (India)).