Data Processing Delays - Contact Ingestion and Analytics Delays (US West only)

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 05:57 CEST

Monitoring

The system has caught up and we are continuing to monitor the status.
Posted Jul 03, 2025 - 05:52 CEST

Identified

Our data processing infrastructure is running behind which is causing delays to contact ingestion and updates. Analytics may experience some delays as well. No data has been lost and the system should be caught up shortly.
Posted Jul 03, 2025 - 04:56 CEST
This incident affected: CRM (Contacts - US (West)).