Engagement Platform: Reports of top-ups not being reflected in wallet balances.
Incident Report for Bird
Resolved
This incident has been resolved.
Posted Feb 26, 2024 - 21:43 CET
Investigating
We are investigating some reports that top-ups are not being reflected in wallet balances.
Posted Feb 26, 2024 - 15:45 CET