10DLC SMS campaign registration or number provisioning delays - United States

Incident Report for Bird

Resolved

The 10DLC campaign registration or number provisioning delays have been resolved, and service has returned to normal.
Posted Feb 06, 2025 - 01:07 CET

Identified

We are experiencing delays with 10DLC campaign registration and number provisioning. Our teams are working to restore normal processing times.
Posted Feb 05, 2025 - 10:51 CET
This incident affected: Connectivity Platform (SMS - Connectivity - NORAM).