CSV imports screen for Contacts appears to get stuck on the "Finish" step

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 20:07 CEST

Identified

We've identified a UI bug that in some instances prevents customers from being moved to the next screen after clicking the "Finish" button. The bug only impacts the UI from advancing to the completed step; the import is actually triggered and being processed in the background. Going to "Contacts > Data Management > Imports" should let customers see that the import has actually started. We will update this page again once the UI bug has been fixed and deployed.
Posted Apr 11, 2025 - 18:27 CEST

Investigating

Import CSV for contacts isn't working as expected.

We are investigating the situation and we will provide an update as soon as we have additional information.
Posted Apr 11, 2025 - 17:36 CEST
This incident affected: CRM (Contacts - Europe, Contacts - US (West), Contacts - Asia (India)).