Email channel installation is experiencing issues
Incident Report for Bird
Resolved
Our engineering team has mitigated this incident and confirmed that email channel creation is fully operational. We apologise for any inconvenience this has caused you.
Posted Apr 15, 2024 - 13:00 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 15, 2024 - 12:50 CEST
Investigating
Our engineering team is actively addressing an issue arising during email channel installation. Customers attempting to use the "add domain" option are encountering errors, hindering their ability to add a domain successfully.
Posted Apr 15, 2024 - 12:34 CEST
This incident affected: CRM (Channels - Europe, Channels - US (West), Channels - Asia (India)).