Failing WhatsApp Carousel Templates

Incident Report for Bird

Resolved

Issue has been resolved and normal service functionality restored
Posted May 29, 2025 - 09:51 CEST

Investigating

We are investigating failures in sending WhatsApp Carousel Templates.
Posted May 28, 2025 - 12:29 CEST