Intermittent issues installing WhatsApp channels

Incident Report for Bird

Identified

We've identified the issue and are working with Meta (WhatsApp) to resolve it.
Posted Dec 01, 2025 - 11:58 CET

Investigating

We are investigating issues preventing some customers from installing WhatsApp channels for pre-verified numbers only.
Posted Nov 27, 2025 - 11:57 CET
This incident affects: CRM (Channels - Europe, Channels - US (West), Channels - Asia (India)).