Flow Logs failures in EU

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 23:36 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2026 - 23:30 CEST

Identified

We have identified the issue and are testing a fix. We expect logs to be available again with in an hour.
Posted Sep 21, 2026 - 21:09 CEST

Update

The current failure is in log retrieval not flow runs. Flows are running with out impact. Logs are failing to load upon request.
Posted Sep 21, 2026 - 20:13 CEST

Update

We are continuing to investigate this issue.
Posted Sep 21, 2026 - 20:12 CEST

Investigating

We are currently investigating an issue in EU that is causing some flows to fail.
Posted Sep 21, 2026 - 20:08 CEST
This incident affected: Engagement Platform / CRM (Flows - Europe).