WhatsApp message delivery issues

Incident Report for Bird

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 20:22 CEST

Identified

We are continuing to monitor increased WhatsApp message delivery failures caused by ongoing disruptions in Meta’s services, as confirmed by Meta.
Posted Jun 12, 2026 - 17:05 CEST

Investigating

We are investigating increased WhatsApp message delivery failures caused by connectivity issues with Meta services. Customers may experience delays or failures when sending WhatsApp messages.

Our team is actively monitoring the situation and working to mitigate the impact. We will provide further updates as more information becomes available.
Posted Jun 12, 2026 - 16:10 CEST
This incident affected: CRM (Channels - Europe, Channels - US (West), Channels - Asia (India)) and Connectivity Platform (WhatsApp Channel).