10DLC SMS campaign registration or number provisioning delays

Incident Report for Bird

Resolved

The 10DLC campaign registration or number provisioning delays have been resolved, and service has returned to normal.
Posted Mar 10, 2025 - 23:19 CET

Identified

We are experiencing delays with 10DLC campaign registration and number provisioning. Our teams are working to restore normal processing times.
Start time: 27.02.2025 22:25 CET
Posted Feb 28, 2025 - 11:01 CET
This incident affected: Connectivity Platform (SMS - Connectivity - NORAM).