Campaign Delivery System: Campaign Recipient Limits Not Being Honored
Incident Report for Bird
Resolved
Resolved - This incident has been resolved. The segment limitation functionality has been restored and is operating normally. During the incident period (09:56-11:25 AM CET), some campaigns may have exceeded their configured recipient limits. We will be conducting a detailed review to prevent similar situations in the future. Nov 22, 11:25 CET

Monitoring - Our engineering team has deployed a fix and is monitoring all campaign delivery systems to ensure proper segment limitation enforcement. Initial metrics show normal operation. Nov 22, 11:00 CET

Identified - Our engineering team has identified the root cause related to recent campaign functionality improvements and is working on deploying a fix. Containment measures remain in place. Nov 22, 10:22 CET

Investigating - We are investigating an issue with our campaign delivery system's segment limitation controls. Some campaigns may be exceeding configured recipient limits. Our engineering team has implemented immediate containment measures. Nov 22, 10:00 CET
Posted Nov 22, 2024 - 10:00 CET